goto-line and goto-char not working in emacs info mode

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

goto-line and goto-char not working in emacs info mode

Kyaw
Is that the normal behavior? I can't use M-g g and M-g c command in emacs
info mode buffer.
It works in anything else.
Reply | Threaded
Open this post in threaded view
|

Re: goto-line and goto-char not working in emacs info mode

Teemu Likonen-2
Kyaw [2017-10-08 19:55:04+06:30] wrote:

> Is that the normal behavior? I can't use M-g g and M-g c command in
> emacs info mode buffer.

It's normal but probably not wanted behavior. Info documents are big
buffers and the current info node is just narrowed view in that buffer.
Function goto-line operates on the whole buffer, not just on the current
(narrowed) info node.

--
/// Teemu Likonen   - .-..   <https://keybase.io/tlikonen> //
// PGP: 4E10 55DC 84E9 DFF6 13D7 8557 719D 69D3 2453 9450 ///

signature.asc (497 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: goto-line and goto-char not working in emacs info mode

Emanuel Berg-4
Teemu Likonen wrote:

>> Is that the normal behavior? I can't use M-g
>> g and M-g c command in emacs info
>> mode buffer.
>
> It's normal but probably not wanted behavior.
> Info documents are big buffers and the
> current info node is just narrowed view in
> that buffer. Function goto-line operates on
> the whole buffer, not just on the current
> (narrowed) info node.

There is some resistance to learing how to
navigate the info system. Not just the buffers,
but the tree system itself. Just keep it up and
it'll come to you.

--
underground experts united
http://user.it.uu.se/~embe8573


Reply | Threaded
Open this post in threaded view
|

Re: goto-line and goto-char not working in emacs info mode

Kyaw
In reply to this post by Kyaw
I understand it now that I feel inconsistency instead of harmony. I shall
help change the emacs when I achieve the total understanding of the inner
working of emacs. I think that It shouldn't be that way. It's itching my
perfectionism.

On Sun, Oct 8, 2017 at 7:55 PM, Kyaw <[hidden email]> wrote:

> Is that the normal behavior? I can't use M-g g and M-g c command in emacs
> info mode buffer.
> It works in anything else.
>