bug#41926: package.el: please improve dependency handling during updates

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

bug#41926: package.el: please improve dependency handling during updates

Thomas Klausner-5
Hi!

I recently did

list-packages
U
x

to update all installed packages. Afterwards I found errors in the log
because lsp-ui needed a newer version of one of its dependencies, but
that had not been upgraded yet.
(see https://github.com/emacs-lsp/lsp-ui/issues/462)

Please improve the package handling that the packages are updated from
bottom to top, dependency wise (i.e. if foo needs bar, then bar should
be updated first).

Thanks,
 Thomas