bug#38559: svg-clock.el 1.1: It calls function make-decoded-time which is new in emacs 27

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

bug#38559: svg-clock.el 1.1: It calls function make-decoded-time which is new in emacs 27

HaiJun Zhang
So it doesn’t support emacs older than 27.

 ;; Package-Requires: ((svg “0.1") (emacs "25.0"))
Reply | Threaded
Open this post in threaded view
|

bug#38559: svg-clock.el 1.1: It calls function make-decoded-time which is new in emacs 27

Ulf Jasper
Am 10.12.2019 um 21:17 (+0800) schrieb HaiJun Zhang:
> So it doesn’t support emacs older than 27.
>
>  ;; Package-Requires: ((svg “0.1") (emacs "25.0"))

Thanks for reporting.  I'll have a look.



Reply | Threaded
Open this post in threaded view
|

bug#38559: svg-clock.el 1.1: It calls function make-decoded-time which is new in emacs 27

Ulf Jasper
Am 11.12.2019 um 16:13 (+0100) schrieb Ulf Jasper:
> Am 10.12.2019 um 21:17 (+0800) schrieb HaiJun Zhang:
>> So it doesn’t support emacs older than 27.
>>
>>  ;; Package-Requires: ((svg “0.1") (emacs "25.0"))
>
> Thanks for reporting.  I'll have a look.

Changed the Package-Requires statement to ((svg "1.0") (emacs "27.0")).

Next step would be to increase the package version of svg-clock from 1.1
to 1.2 to trigger deployment of the modified version.  But this new
version would be visible only for emacs 27 (and up) iiuc.  Emacs<26
users would still see the broken version.

Shall we create and deploy a 1.1a (or something) that makes svg-clock
usable again for emacsen before 27?