bug#38496: Issue with Saving HTML

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

bug#38496: Issue with Saving HTML

Kasra Sadeghi
When I paste the following into a new buffer in emacs and I try to save it (C-x s), emacs stalls, appears to leak memory, and becomes unresponsive.

name="UPENNG-PM_SEAS_RESEARCH_ADVISOR_1" 

I have a video of this taken with OBS, but I'm not sure how to submit that according to the guidelines. I'm using emacs 26.3.1 of 2019-08-29 on arch linux.
Reply | Threaded
Open this post in threaded view
|

bug#38496: Issue with Saving HTML

Lars Ingebrigtsen
Kasra Sadeghi <[hidden email]> writes:

> When I paste the following into a new buffer in emacs and I try to
> save it (C-x s), emacs stalls, appears to leak memory, and becomes
> unresponsive.
>
> name="UPENNG-PM_SEAS_RESEARCH_ADVISOR_1"
>
> I have a video of this taken with OBS, but I'm not sure how to submit that
> according to the guidelines. I'm using emacs 26.3.1 of 2019-08-29 on arch linux.

I'm unable to reproduce this bug.  I tried starting Emacs with "emacs
-Q", opening /tmp/a.html, putting the line you quote in it and saving
the buffer with `C-x s', and the file is saved as usual.

Are there any additional steps needed to reproduce the bug?

--
(domestic pets only, the antidote for overdose, milk.)
   bloggy blog: http://lars.ingebrigtsen.no



Reply | Threaded
Open this post in threaded view
|

bug#38496: Issue with Saving HTML

Lars Ingebrigtsen
(Please keep the debbugs address in the Cc header -- otherwise your
email won't reach the bug tracker.)

Kasra Sadeghi <[hidden email]> writes:

> I believe it's something in my configuration. I am unable to reproduce it with
> emacs -q. Is there a way to figure out where in my configuration this problem
> may occur?

Try M-: (setq debug-on-error t) RET and then see if you get a
backtrace.  That might give you a hint as to what the problem is.