bug#38023: Update win32 faq: emacs works on windows 10

classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|

bug#38023: Update win32 faq: emacs works on windows 10

Cecilio Pardo

Severity: minor
Tags: documentation patch

diff --git a/doc/misc/efaq-w32.texi b/doc/misc/efaq-w32.texi
index cdd01e47f0..f0bdeaa1a8 100644
--- a/doc/misc/efaq-w32.texi
+++ b/doc/misc/efaq-w32.texi
@@ -126,7 +126,7 @@ Which versions of Windows
 @cindex supported versions of Windows
 
 Emacs @value{EMACSVER} is known to run on all versions of Windows from
-Windows 98 and Windows NT 4.0 through to Windows 8.1.  The Windows
+Windows 98 and Windows NT 4.0 through to Windows 10.  The Windows
 port is built using the Win32 API and supports most features of the X
 version, including variable width fonts, images and tooltips.
 





Reply | Threaded
Open this post in threaded view
|

bug#38023: Update win32 faq: emacs works on windows 10

Eli Zaretskii
> From: Cecilio Pardo <[hidden email]>
> Date: Fri, 01 Nov 2019 20:48:44 +0100
>
> -Windows 98 and Windows NT 4.0 through to Windows 8.1.  The Windows
> +Windows 98 and Windows NT 4.0 through to Windows 10.  The Windows

I'd rather we said something that didn't require us to go back and fix
it every year.  Basically, all the Windows versions of the NT family
are supported, and will be supported in the future.

Thanks.



Reply | Threaded
Open this post in threaded view
|

bug#38023: Update win32 faq: emacs works on windows 10

Cecilio Pardo-2

>> -Windows 98 and Windows NT 4.0 through to Windows 8.1.  The Windows
>> +Windows 98 and Windows NT 4.0 through to Windows 10.  The Windows
>
> I'd rather we said something that didn't require us to go back and fix
> it every year.  Basically, all the Windows versions of the NT family
> are supported, and will be supported in the future.

Maybe something like this?

diff --git a/doc/misc/efaq-w32.texi b/doc/misc/efaq-w32.texi
index cdd01e47f0..4dddfeeb16 100644
--- a/doc/misc/efaq-w32.texi
+++ b/doc/misc/efaq-w32.texi
@@ -126,7 +126,7 @@ Which versions of Windows
 @cindex supported versions of Windows
 
 Emacs @value{EMACSVER} is known to run on all versions of Windows from
-Windows 98 and Windows NT 4.0 through to Windows 8.1.  The Windows
+Windows 98 and Windows NT 4.0 through current ones.  The Windows
 port is built using the Win32 API and supports most features of the X
 version, including variable width fonts, images and tooltips.






Reply | Threaded
Open this post in threaded view
|

bug#38023: Update win32 faq: emacs works on windows 10

Eli Zaretskii
> From: Cecilio Pardo <[hidden email]>
> Cc: Cecilio Pardo <[hidden email]>,  [hidden email]
> Date: Sat, 02 Nov 2019 02:43:54 +0100
>
> > I'd rather we said something that didn't require us to go back and fix
> > it every year.  Basically, all the Windows versions of the NT family
> > are supported, and will be supported in the future.
>
> Maybe something like this?
>
> diff --git a/doc/misc/efaq-w32.texi b/doc/misc/efaq-w32.texi
> index cdd01e47f0..4dddfeeb16 100644
> --- a/doc/misc/efaq-w32.texi
> +++ b/doc/misc/efaq-w32.texi
> @@ -126,7 +126,7 @@ Which versions of Windows
>  @cindex supported versions of Windows
>  
>  Emacs @value{EMACSVER} is known to run on all versions of Windows from
> -Windows 98 and Windows NT 4.0 through to Windows 8.1.  The Windows
> +Windows 98 and Windows NT 4.0 through current ones.  The Windows

I'm admittedly splitting hair, but I think this is slightly better:

  Emacs @value{EMACSVER} is known to run on all versions of Windows 9X
  from Windows 98 onward, and all versions of the NT family starting
  from NT 4.0.

Thanks.

 



Reply | Threaded
Open this post in threaded view
|

bug#38023: Update win32 faq: emacs works on windows 10

Stefan Kangas
Eli Zaretskii <[hidden email]> writes:

>> From: Cecilio Pardo <[hidden email]>
>> Cc: Cecilio Pardo <[hidden email]>,  [hidden email]
>> Date: Sat, 02 Nov 2019 02:43:54 +0100
>>
>> > I'd rather we said something that didn't require us to go back and fix
>> > it every year.  Basically, all the Windows versions of the NT family
>> > are supported, and will be supported in the future.
>>
>> Maybe something like this?
>>
>> diff --git a/doc/misc/efaq-w32.texi b/doc/misc/efaq-w32.texi
>> index cdd01e47f0..4dddfeeb16 100644
>> --- a/doc/misc/efaq-w32.texi
>> +++ b/doc/misc/efaq-w32.texi
>> @@ -126,7 +126,7 @@ Which versions of Windows
>>  @cindex supported versions of Windows
>>  
>>  Emacs @value{EMACSVER} is known to run on all versions of Windows from
>> -Windows 98 and Windows NT 4.0 through to Windows 8.1.  The Windows
>> +Windows 98 and Windows NT 4.0 through current ones.  The Windows
>
> I'm admittedly splitting hair, but I think this is slightly better:
>
>   Emacs @value{EMACSVER} is known to run on all versions of Windows 9X
>   from Windows 98 onward, and all versions of the NT family starting
>   from NT 4.0.

Personally, I know very little about Microsoft Windows.  Only by
reading this list have I recently learned that Windows 10 (or 8 or
whatever) is part of the "NT family" of Windows.  And only two minutes
ago I checked Wikipedia and learned that Windows XP is also part of
that same family.

I would guess that some less tech-savvy users than me (you would
perhaps think there are none, but there are!) might be confused by the
above, and not immediately realize that the "NT family" includes also
all the recent versions of Windows.

So perhaps we should keep "the latest version" or something like that.

Best regards,
Stefan Kangas



Reply | Threaded
Open this post in threaded view
|

bug#38023: Update win32 faq: emacs works on windows 10

Eli Zaretskii
> From: Stefan Kangas <[hidden email]>
> Cc: Cecilio Pardo <[hidden email]>,  [hidden email],
>   [hidden email]
> Date: Fri, 08 Nov 2019 01:25:15 +0100
>
> > I'm admittedly splitting hair, but I think this is slightly better:
> >
> >   Emacs @value{EMACSVER} is known to run on all versions of Windows 9X
> >   from Windows 98 onward, and all versions of the NT family starting
> >   from NT 4.0.
>
> Personally, I know very little about Microsoft Windows.  Only by
> reading this list have I recently learned that Windows 10 (or 8 or
> whatever) is part of the "NT family" of Windows.  And only two minutes
> ago I checked Wikipedia and learned that Windows XP is also part of
> that same family.

Well, that FAQ is for users of MS-Windows...

> I would guess that some less tech-savvy users than me (you would
> perhaps think there are none, but there are!) might be confused by the
> above, and not immediately realize that the "NT family" includes also
> all the recent versions of Windows.
>
> So perhaps we should keep "the latest version" or something like that.

How about this:

  Emacs @value{EMACSVER} is known to run on all versions of Windows 9X
  from Windows 98 onward, and all versions of the NT family starting
  from NT 4.0; this includes all the modern versions from Windows XP
  and on.



Reply | Threaded
Open this post in threaded view
|

bug#38023: Update win32 faq: emacs works on windows 10

Stefan Kangas
Eli Zaretskii <[hidden email]> writes:

>> I would guess that some less tech-savvy users than me (you would
>> perhaps think there are none, but there are!) might be confused by the
>> above, and not immediately realize that the "NT family" includes also
>> all the recent versions of Windows.
>>
>> So perhaps we should keep "the latest version" or something like that.
>
> How about this:
>
>   Emacs @value{EMACSVER} is known to run on all versions of Windows 9X
>   from Windows 98 onward, and all versions of the NT family starting
>   from NT 4.0; this includes all the modern versions from Windows XP
>   and on.

Thank you, that is much better.  I suggest that we install that
change.

Best regards,
Stefan Kangas



Reply | Threaded
Open this post in threaded view
|

bug#38023: Update win32 faq: emacs works on windows 10

Eli Zaretskii
> From: Stefan Kangas <[hidden email]>
> Cc: [hidden email],  [hidden email],  [hidden email]
> Date: Fri, 08 Nov 2019 13:38:52 +0100
>
> >   Emacs @value{EMACSVER} is known to run on all versions of Windows 9X
> >   from Windows 98 onward, and all versions of the NT family starting
> >   from NT 4.0; this includes all the modern versions from Windows XP
> >   and on.
>
> Thank you, that is much better.  I suggest that we install that
> change.

Feel free to install, and thanks.



Reply | Threaded
Open this post in threaded view
|

bug#38023: Update win32 faq: emacs works on windows 10

Stefan Kangas
close 38023 27.1
thanks

Eli Zaretskii <[hidden email]> writes:

>> From: Stefan Kangas <[hidden email]>
>> Cc: [hidden email],  [hidden email],  [hidden email]
>> Date: Fri, 08 Nov 2019 13:38:52 +0100
>>
>> >   Emacs @value{EMACSVER} is known to run on all versions of Windows 9X
>> >   from Windows 98 onward, and all versions of the NT family starting
>> >   from NT 4.0; this includes all the modern versions from Windows XP
>> >   and on.
>>
>> Thank you, that is much better.  I suggest that we install that
>> change.
>
> Feel free to install, and thanks.

Pushed in your name as commit 05167c1173.  Closing the bug.

Best regards,
Stefan Kangas



Reply | Threaded
Open this post in threaded view
|

bug#38023: Update win32 faq: emacs works on windows 10

Tomas Nordin-2
In reply to this post by Eli Zaretskii
Eli Zaretskii <[hidden email]> writes:

> How about this:
>
>   Emacs @value{EMACSVER} is known to run on all versions of Windows 9X
>   from Windows 98 onward, and all versions of the NT family starting
>   from NT 4.0; this includes all the modern versions from Windows XP
>   and on.

A bit late jump-in from my side but, to me this text first imply that
all versions of 9X is supported but in the same breath say it runs from
98 onward. But was there any more 9X after 98? Isn't it more like that
98 is supported and then all versions of NT...

--
Tomas



Reply | Threaded
Open this post in threaded view
|

bug#38023: Update win32 faq: emacs works on windows 10

martin rudalics
> But was there any more 9X after 98?

Windows ME.

martin



Reply | Threaded
Open this post in threaded view
|

bug#38023: Update win32 faq: emacs works on windows 10

Eli Zaretskii
In reply to this post by Tomas Nordin-2
> From: Tomas Nordin <[hidden email]>
> Cc: [hidden email], [hidden email], [hidden email]
> Date: Sat, 16 Nov 2019 11:20:56 +0100
>
> >   Emacs @value{EMACSVER} is known to run on all versions of Windows 9X
> >   from Windows 98 onward, and all versions of the NT family starting
> >   from NT 4.0; this includes all the modern versions from Windows XP
> >   and on.
>
> A bit late jump-in from my side but, to me this text first imply that
> all versions of 9X is supported but in the same breath say it runs from
> 98 onward. But was there any more 9X after 98?

Yes, there was Windows Me.