bug#28067: Mac OS High Sierra Beta 5 : Unable to load color ...

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

bug#28067: Mac OS High Sierra Beta 5 : Unable to load color ...

Mario Paumann

Hello !

Just upgraded to High Sierra Beta 5 and now Emacs shows my files black on black.

This bug report was originaly posted to https://github.com/caldwell/build-emacs/issues/65;

on High Sierra Beta 4 i didn't have this problem

using brew emacs has exact the same problem


After removing all .emacs* it's kind of more visible but i see the general cause in Messages

Warning: arch-dependent data dir '/Users/build/workspace/Emacs-Multi-Build/label/mavericks/emacs-source/nextstep/Emacs.app/Contents/MacOS/libexec/': No such file or directory
Unable to load color "grey75"
Unable to load color "grey90"
Unable to load color "grey20"
Unable to load color "grey75" [2 times]
Unable to load color "grey95"
Unable to load color "grey90"
Unable to load color "grey20"
Unable to load color "gray60"
Unable to load color "gray80"
Unable to load color "gray40"
For information about GNU Emacs and the GNU system, type C-h C-a.
Unable to load color "grey75"
Unable to load color "RoyalBlue3"
Unable to load color "medium blue"
Mark set

The status row, which seems to use this colors, is completely black.

bildschirmfoto 2017-08-09 um 12 39 03

I googled, and found older similiar problems
the only solution for me now is :

rm ~/Library/Colors/Emacs.clr
rm -rf .emacs.d/

before starting emacs. Then colors seem ok.
closing (with autosave) and restarting, colors are messed up again.

Starting emacs with my temporary solution :
bildschirmfoto 2017-08-09 um 12 53 16

Restarting emacs :
bildschirmfoto 2017-08-09 um 12 53 37

Thank you for your help, Mario
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

bug#28067: Mac OS High Sierra Beta 5 : Unable to load color ...

John Mastro
Mario Paumann <[hidden email]> wrote:
> Just upgraded to High Sierra Beta 5 and now Emacs shows my files black
> on black.
>
> This bug report was originaly posted to
> https://github.com/caldwell/build-emacs/issues/65; on High Sierra Beta
> 4 i didn't have this problem using brew emacs has exact the same
> problem

[snip]

> I googled, and found older similiar problems
> the only solution for me now is :
>
> rm ~/Library/Colors/Emacs.clr
> rm -rf .emacs.d/
>
> before starting emacs. Then colors seem ok.
> closing (with autosave) and restarting, colors are messed up again.

Just for reference for anyone working on this, a discussion in
which this was mentioned on emacs-devel is here[1] and the workaround
was reported here[2]. That discussion ended with the OP opening a bug
with Apple[3].

        John

[1]: https://lists.gnu.org/archive/html/emacs-devel/2017-08/msg00178.html
[2]: https://lists.gnu.org/archive/html/emacs-devel/2017-08/msg00184.html
[3]: https://lists.gnu.org/archive/html/emacs-devel/2017-08/msg00187.html



Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

bug#28067: Mac OS High Sierra Beta 5 : Unable to load color ...

Mario Paumann
Bug is solved in High Sierra Beta 6. Sorry for opening Bug @GNU. Thanx, mario

Am 12.08.2017 um 20:52 schrieb John Mastro <[hidden email]>:

Just for reference for anyone working on this, a discussion in
which this was mentioned on emacs-devel is here[1] and the workaround
was reported here[2]. That discussion ended with the OP opening a bug
with Apple[3].

       John

[1]: https://lists.gnu.org/archive/html/emacs-devel/2017-08/msg00178.html
[2]: https://lists.gnu.org/archive/html/emacs-devel/2017-08/msg00184.html
[3]: https://lists.gnu.org/archive/html/emacs-devel/2017-08/msg00187.html

Loading...