bug#27989: 26.0.50; Completion in shell-mode not working properly on MS-Windows

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

bug#27989: 26.0.50; Completion in shell-mode not working properly on MS-Windows

Chris Zheng

After applying commit 3a8d0cc825635e07da2a90c4ac987b476fc9b05d, the
completion function does not work properly on MS-Windows.

1. Start emacs with “-Q”, for example in emacs/src directory.
2. M-x shell. A cmd shell will appear.
3. Type “cd ./” in the *shell* buffer. Press TAB, the minibuffer
says “Complete, but not unique”. Press TAB again, the minibuffer
says “No completions”.

The expected (old) behavior is

Possible completions are:
../ ./
bitmaps/ deps/

in the *Completions* buffer.


Thank you for your time.

Best regards,

Chris



In GNU Emacs 26.0.50 (build 1, x86_64-w64-mingw32)
 of 2017-08-06 built on KAEL
Repository revision: cbea38e5c4af5386192fb9a48ef4fca5080d6561
Windowing system distributor 'Microsoft Corp.', version 6.3.9600

Configured using:
 'configure --prefix=/tmp/emacs --without-imagemagick --without-dbus
 --with-modules 'CFLAGS=-O2 -ftree-vectorize -fopt-info -g0
 -mtune=native''

Configured features:
XPM JPEG TIFF GIF PNG RSVG SOUND NOTIFY ACL GNUTLS LIBXML2 ZLIB
TOOLKIT_SCROLL_BARS MODULES

Important settings:
  value of $LC_CTYPE: zh_CN.UTF-8
  value of $LANG: zh_CN.UTF-8
  locale-coding-system: cp936



Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

bug#27989: 26.0.50; Completion in shell-mode not working properly on MS-Windows

Eli Zaretskii
> Date: Mon, 07 Aug 2017 01:33:11 +0800
> From: Chris Zheng <[hidden email]>
>
>
> After applying commit 3a8d0cc825635e07da2a90c4ac987b476fc9b05d, the
> completion function does not work properly on MS-Windows.
>
> 1. Start emacs with “-Q”, for example in emacs/src directory.
> 2. M-x shell. A cmd shell will appear.
> 3. Type “cd ./” in the *shell* buffer. Press TAB, the minibuffer
> says “Complete, but not unique”. Press TAB again, the minibuffer
> says “No completions”.
>
> The expected (old) behavior is
>
> Possible completions are:
> ../ ./
> bitmaps/ deps/
>
> in the *Completions* buffer.
>
>
> Thank you for your time.

Thanks, this is now fixed by a685d9d.



Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

bug#27989: 26.0.50; Completion in shell-mode not working properly on MS-Windows

Chris Zheng
In reply to this post by Chris Zheng

Thank you, Eli. It is fixed.



Loading...