bug#27329: Emacs 25.2.1 M-x list-packages crashes on https://melpa (SSL problem ?)

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

bug#27329: Emacs 25.2.1 M-x list-packages crashes on https://melpa (SSL problem ?)

Pierre Albarède
Hello,

with
GNU Emacs 25.2.1 (x86_64-apple-darwin13.4.0, NS appkit-1265.21 Version 10.9.5
(Build 13F1911))
 of 2017-04-21
downloaded from from https://emacsformacosx.com/about

launch Emacs, for example, in shell :

% /Applications/Emacs-25.2.app/Contents/MacOS/Emacs -Q

In Emacs, evaluate this :

(require 'package)

(add-to-list 'package-archives
             '("melpa" . "https://melpa.org/packages/"))


M-x list-packages

Emacs crashes.

The problem did not exist in Emacs 25.1 and disappears when https is replaced by
http.

See also https://github.com/melpa/melpa/issues/4791



Best regards.







Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

bug#27329: Emacs 25.2.1 M-x list-packages crashes on https://melpa (SSL problem ?)

Paul Eggert
I cannot reproduce the problem on my somewhat-different platform (Ubuntu 16.04.2
LTS, x86-64, configured --with-ns so that Emacs reports "NS gnustep-gnu-0.24.0"
as the UI). Assuming you still have the problem, can you please build Emacs with
CFLAGS='-g3 -O0', run Emacs under GDB, and send a backtrace of the crash?



Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

bug#27329: Emacs 25.2.1 M-x list-packages crashes on https://melpa (SSL problem ?)

Alan Third
In reply to this post by Pierre Albarède
On Sun, Jun 11, 2017 at 10:27:10AM +0200, Pierre Albarède wrote:

> with
> GNU Emacs 25.2.1 (x86_64-apple-darwin13.4.0, NS appkit-1265.21
> Version 10.9.5 (Build 13F1911)) of 2017-04-21
> downloaded from from https://emacsformacosx.com/about
>
> launch Emacs, for example, in shell :
>
> % /Applications/Emacs-25.2.app/Contents/MacOS/Emacs -Q
>
> In Emacs, evaluate this :
>
> (require 'package)
>
> (add-to-list 'package-archives
>     '("melpa" . "https://melpa.org/packages/"))
>
>
> M-x list-packages
>
> Emacs crashes.

I can’t replicate this using

    GNU Emacs 25.2.1 (x86_64-apple-darwin16.5.0, NS appkit-1504.82
    Version 10.12.4 (Build 16E195)) of 2017-04-29

built myself.

This looks like it’s probably relevant

    https://github.com/caldwell/build-emacs/issues/60

but has no clear resolution.

--
Alan Third



Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

bug#27329: Emacs 25.2.1 M-x list-packages crashes on https://melpa (SSL problem ?)

Paul Eggert
In reply to this post by Pierre Albarède
As this appears to be a GnuTLS packaging problem on emacsformacos.com,
and not an Emacs bug per se, I suggest that we close the Emacs bug report.




Loading...