bug#26607: 25.1; Installed packages get status 'dependency' after removing obsolete versions.

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

bug#26607: 25.1; Installed packages get status 'dependency' after removing obsolete versions.

Julian H


When updating a package and then deleting the obsolete verion, the current installed packages don't have the status 'installed' afterwards but the status 'dependency'.

How to replicate:
1. M-x package-list-packages
2. M-x package-menu-mark-obsolete-for-deletion
3. delete marked packages

Then the status of the currently installed version becomes
'dependency'.  For example, this might be problematic when using M-x
package-autoremove, because these packages would be deleted.




Reply | Threaded
Open this post in threaded view
|

bug#26607: 25.1; Installed packages get status 'dependency' after removing obsolete versions.

Lars Ingebrigtsen
Julian H <[hidden email]> writes:

> When updating a package and then deleting the obsolete verion, the
> current installed packages don't have the status 'installed'
> afterwards but the status 'dependency'.
>
> How to replicate:
> 1. M-x package-list-packages
> 2. M-x package-menu-mark-obsolete-for-deletion
> 3. delete marked packages

(This bug report unfortunately got no response at the time.)

With 3), do you mean `M-x package-menu-execute' (i.e., `x')?

> Then the status of the currently installed version becomes
> 'dependency'.  For example, this might be problematic when using M-x
> package-autoremove, because these packages would be deleted.

In any case, I can't reproduce this bug, because I don't seem to have
any obsolete packages installed.  Anybody else?

Are you still seeing this bug in more recent versions of Emacs?

--
(domestic pets only, the antidote for overdose, milk.)
   bloggy blog: http://lars.ingebrigtsen.no



Reply | Threaded
Open this post in threaded view
|

bug#26607: 25.1; Installed packages get status 'dependency' after removing obsolete versions.

Lars Ingebrigtsen
Lars Ingebrigtsen <[hidden email]> writes:

> Are you still seeing this bug in more recent versions of Emacs?

More information was requested, but no response was given within a
month, so I'm closing this bug report.  If the problem still exists,
please respond to this email and we'll reopen the bug report.

--
(domestic pets only, the antidote for overdose, milk.)
   bloggy blog: http://lars.ingebrigtsen.no