Updating from Emacs 23.3.1 to 25.3

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Updating from Emacs 23.3.1 to 25.3

Douglas Harter

I am looking for some help with Upgrading Emacs. My current version is

GNU Emacs 23.3.1. EMacs is now up to 25.3 and has a different

directory structure. my .emacs has over 100 lines and doesn't run on

25.3 and I have one of my utilities which has been completely

rewritten on 25.3 and won't run on 23.3.1.

 

I have tried Googling updating Emacs and have not found any detailed

help on what to do. Could someone give me some help?

 

Reply | Threaded
Open this post in threaded view
|

Re: Updating from Emacs 23.3.1 to 25.3

Bastien Guerry-5
Hi Doug,

I suggest trying to launch Emacs with this command:

~$ emacs -Q

then see if it starts okay.

If not, you probably need to reinstall GNU Emacs from scratch.

If yes, you can test your .emacs file by bisecting it: test the
first half and see if Emacs starts correctly, etc.

For detailed help on specific aspects of your configuration,
you need to give more details if you want someone to help.

Best,

--
 Bastien

Reply | Threaded
Open this post in threaded view
|

Re: Updating from Emacs 23.3.1 to 25.3

Winston
In reply to this post by Douglas Harter
"Doug Harter" <[hidden email]> writes:
> I am looking for some help with Upgrading Emacs. My current version is
> GNU Emacs 23.3.1. EMacs is now up to 25.3 and has a different
> directory structure. my .emacs has over 100 lines and doesn't run on
> 25.3 and I have one of my utilities which has been completely
> rewritten on 25.3 and won't run on 23.3.1.

If your new Emacs will start without your ~/.emacs, you could insert the
contents of .emacs into *scratch* and execute it statement by statement
until something fails.

Is your .emacs mostly code you wrote, or is it all
(custom-set-variables, (custom-set-faces, and the like generated by
Emacs itself as a result of settings changes and such?  If it's entirely
Emacs generated and now prevents Emacs from running, that's probably
worth a bug report.

As to changes that prevent Emacs from even starting, I vaguely recall
that
        (rplaca (assq 27 universal-argument-map) ....

had that effect, because Emacs 24.4 no longer had a binding for ESC/27
there, but my memory could be wrong.  Key and keymap changes you made
yourself directly in .emacs are probably a good place to look, though.

HTH,
 -WBE

Reply | Threaded
Open this post in threaded view
|

RE: Updating from Emacs 23.3.1 to 25.3

PawWriter
In reply to this post by Douglas Harter
I know I have to do that, I just think I need someone here with me to walk
me thru it. I already have 25.3 on my computer, in an Emacs1 directory, but
the directory structure is so different, I have so much in my .emacs, and I
need updated versions of many of the procedures and am not sure where to get
them all. That is why I specified where I live in this username (near
Harrisburg, PA). I have tried local computer shops, but nobody is that
familiar with Emacs.