Unable to use `package-refresh-contents`: Bad signature from GNU ELPA Signing Agent

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Unable to use `package-refresh-contents`: Bad signature from GNU ELPA Signing Agent

Nicky Chorley
Hi all,

I'm running Emacs 25.3.1 on Slackware Linux 14.2 and `M-x
package-refresh-contents` is giving the following error:

Failed to verify signature archive-contents.sig:
Bad signature from 474F05837FBDEF9B GNU ELPA Signing Agent
<[hidden email]>
Command output:
gpg: Signature made Fri 08 Feb 2019 10:15:04 PM GMT using DSA key ID 7FBDEF9B
gpg: BAD signature from "GNU ELPA Signing Agent <[hidden email]>"

I don't recall changing anything in my config recently. Just to see if
that was causing a problem, I did remove my config (.emacs and
.emacs.d), but the problem persisted.

Any ideas about what's causing this?

Thanks,

Nicky Chorley

Reply | Threaded
Open this post in threaded view
|

Re: Unable to use `package-refresh-contents`: Bad signature from GNU ELPA Signing Agent

Robert Pluim
Nicky Chorley <[hidden email]> writes:

> Hi all,
>
> I'm running Emacs 25.3.1 on Slackware Linux 14.2 and `M-x
> package-refresh-contents` is giving the following error:
>
> Failed to verify signature archive-contents.sig:
> Bad signature from 474F05837FBDEF9B GNU ELPA Signing Agent
> <[hidden email]>
> Command output:
> gpg: Signature made Fri 08 Feb 2019 10:15:04 PM GMT using DSA key ID 7FBDEF9B
> gpg: BAD signature from "GNU ELPA Signing Agent <[hidden email]>"
>
> I don't recall changing anything in my config recently. Just to see if
> that was causing a problem, I did remove my config (.emacs and
> .emacs.d), but the problem persisted.
>
> Any ideas about what's causing this?

My crystal ball says youʼre using http to download the archives. Try
switching to https.

If that solves it you have a broken proxy somewhere between you and
the package archive server.

Robert

Reply | Threaded
Open this post in threaded view
|

Re: Unable to use `package-refresh-contents`: Bad signature from GNU ELPA Signing Agent

Stefan Monnier
In reply to this post by Nicky Chorley
> I'm running Emacs 25.3.1 on Slackware Linux 14.2 and `M-x
> package-refresh-contents` is giving the following error:
>
> Failed to verify signature archive-contents.sig:

FWIW, the build scripts on elpa.gnu.org can occasionally end up with
a stale .sig for a short amount of time (known problem that we should
fix, obviously, but not high enough on the todo list), so maybe you just
got unlucky.

In any case, please report those problems via `M-x report-emacs-bug`.


        Stefan