Re: Cannot run executable from eshell

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: Cannot run executable from eshell

Tomas Zerolo
On Thu, Mar 19, 2020 at 02:18:31PM +0000, Roy Lemmon wrote:
> Hi,
>
>
> I have an executable (guix) in a directory under my home directory.

Is that a "real" executable? Or a script?

>                                                                     I am
> using eshell. I add that directory to PATH. But when I run the command, the
> executable is not found. I have tried various methods such as addpath etc.
> But eshell doesnt seem to search in that directory and find the executable.
> If I give the full directory on the command line, it works.
>
> See below:
>
> $ /home/rlemmon/.guix-profile/bin/guix works correctly
>
> $ guix does not work
I doubt the error message looks like that ;-P

Now seriously: perhaps the error message provides some hints
for us to help you.

Sometimes (happens most often with shell scripts) you get
a confusing error message which might lead you to believe
the script was not found while the problem is that the
interpreter for your script isn't found [1]. In your case
possibly guile.

cheers

[1] Ok, ok -- for binaries it's the same (assuming you're
   "on" GNU/Linux, that is). The interpreter is then ld.so,
   but if your system doesn't find that...

-- tomás

signature.asc (205 bytes) Download Attachment