Emacs 22.0.50 fails to compile: Symbol's value as variable is void: flyspell-mode-map

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Emacs 22.0.50 fails to compile: Symbol's value as variable is void: flyspell-mode-map

Bof-4
Hello,

I am having problems compiling Emacs 22.0.50. The compilation process
fails under the following conditions:

    -- I downloaded the latest CVS from savannah.gnu.org immediately
    before trying to compile it, placing the files into /usr/local.

    -- It is being compiled under Fedora Core 2 on a PIII 700 system
    using gcc version 3.3.3 20040412 (Red Hat Linux 3.3.3-7).

    -- As root, I issued "setarch i386 ./configure" and then "setarch
    i386 make bootstrap." I did not otherwise attempt any modifications
    to the source files or the configuration or make processes.

    -- The make bootstrap process failed with the following

        Loading loadup.el (source)...
        Using load-path (/usr/local/emacs/lisp)
        Loading emacs-lisp/byte-run...
        Loading emacs-lisp/backquote...
        Loading subr...
        Loading version.el (source)...
        Loading widget...
        Loading custom...
        Loading emacs-lisp/map-ynp...
        Loading env...
        Loading cus-start...
        Loading international/mule...
        Loading international/mule-conf.el (source)...
        Loading format...
        Loading bindings...
        Loading files...
        Loading cus-face...
        Loading faces...
        Lists of integers (garbage collection statistics) are normal output
        while building Emacs; they do not indicate a problem.
        ((9291 . 6212) (4373 . 0) (548 . 0) 14081 34656 (7 . 4) (17 . 0)
        (813 . 1959))
        Loading loaddefs.el (source)...
        Symbol's value as variable is void: flyspell-mode-map
        make[2]: *** [emacs] Error 255
        make[2]: Leaving directory `/usr/local/emacs/src'
        make[1]: *** [src] Error 2
        make[1]: Leaving directory `/usr/local/emacs'
        make: *** [bootstrap-build] Error 2


FWIW, there is a file in /usr/local/emacs/src named "emacs-22.0.50" that
does run emacs without error messages when loading. I have otherwise not
used it enough to tell if it is completely bug-free.

Please advise on how to get the compliation process to work. Googling
reveals nothing useful.

B. O'Fallon







_______________________________________________
Bug-gnu-emacs mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/bug-gnu-emacs