Disable flymake log about proc-legacy-flymake

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Disable flymake log about proc-legacy-flymake

Alex Branham
I'm using Emacs 26.1RC1.

The buffer *Flymake log* tends to fill up with things like:

Warning [flymake init.el]: Disabling backend flymake-proc-legacy-flymake because (error Can’t find a suitable init function)

because I don't use the legacy flymake stuff. Is there a way to disable this?

I'd like to keep the other warnings/messages, as I've written a few flymake integrations.

Thanks,
Alex

Reply | Threaded
Open this post in threaded view
|

Re: Disable flymake log about proc-legacy-flymake

Stefan Monnier
Problems/suggestions for RC tarballs are matters that need to be
urgently brought to the attention of developers, not fellow users.
So please use `emacs-devel` or M-x report-emacs-bug RET.


        Stefan


Alex Branham <[hidden email]> writes:

> I'm using Emacs 26.1RC1.
>
> The buffer *Flymake log* tends to fill up with things like:
>
> Warning [flymake init.el]: Disabling backend flymake-proc-legacy-flymake
> because (error Can’t find a suitable init function)
>
> because I don't use the legacy flymake stuff. Is there a way to disable this?
>
> I'd like to keep the other warnings/messages, as I've written a few flymake integrations.
>
> Thanks,
> Alex


Reply | Threaded
Open this post in threaded view
|

Re: Disable flymake log about proc-legacy-flymake

João Távora
In reply to this post by Alex Branham
Sorry for being very late on this, but I don't normally read emacs-help.

To solve this, just

(remove-hook 'flymake-diagnostic-functions 'flymake-proc-legacy-flymake)

Somewhere in your init file.

João

On Wed, May 2, 2018, 19:30 Alex Branham <[hidden email]> wrote:

> I'm using Emacs 26.1RC1.
>
> The buffer *Flymake log* tends to fill up with things like:
>
> Warning [flymake init.el]: Disabling backend flymake-proc-legacy-flymake
> because (error Can’t find a suitable init function)
>
> because I don't use the legacy flymake stuff. Is there a way to disable
> this?
>
> I'd like to keep the other warnings/messages, as I've written a few
> flymake integrations.
>
> Thanks,
> Alex
>
>